package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b(?:Mrs?|Sr)\.\s|[^!?.])+[!?.]?`)
var str = `Hello Mr. Jackson. How are you doing today?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}