$re = '/(?:\b(?:Mrs?|Sr)\.\s|[^!?.])+[!?.]?/m';
$str = 'Hello Mr. Jackson. How are you doing today?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);