re = /(?:\b(?:Mrs?|Sr)\.\s|[^!?.])+[!?.]?/m
str = 'Hello Mr. Jackson. How are you doing today?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end