// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\b(?:Mrs?|Sr)\.\s|[^!?.])+[!?.]?").unwrap();
let string = "Hello Mr. Jackson. How are you doing today?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}