using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+-\d+-\d+\s+\d+:\d+:\d+,(?<response_time>\d+),";
string input = @"2021-02-15 18:07:33,936, where the last v";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}