package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+-\d+-\d+\s+\d+:\d+:\d+,(?<response_time>\d+),`)
var str = `2021-02-15 18:07:33,936, where the last v`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}