const regex = /^\d+-\d+-\d+\s+\d+:\d+:\d+,(?<response_time>\d+),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+-\\d+-\\d+\\s+\\d+:\\d+:\\d+,(?<response_time>\\d+),', 'gm')
const str = `2021-02-15 18:07:33,936, where the last v`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}