package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\(?([+]31)-?6(\s?|-)([0-9]\s{0,3}){8}$`)
var str = `+31612345678`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}