$re = '/^\(?([+]31)-?6(\s?|-)([0-9]\s{0,3}){8}$/';
$str = '+31612345678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);