import re
regex = re.compile(r"^\(?([+]31)-?6(\s?|-)([0-9]\s{0,3}){8}$")
test_str = "+31612345678"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")