const regex = /^(?:")?(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:")?(.*)$', 'gm')
const str = `"text1
"text2
"text3
text1
text2
text3`;
const subst = `"$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);