re = /^(?:")?(.*)$/m
str = '"text1
"text2
"text3
text1
text2
text3'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result