#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((((31[- /.](0?[13578]|1[02]))|((29|30)[- /.](0?[1,3-9]|1[0-2])))[- /.](1[6-9]|[2-9]\d)?\d{2})|(29\/0?2[- /.](((1[6-9]|[2-9]\d)?(0[48]|[2468][048]|[13579][26])|((16|[2468][048]|[3579][26])00))))|(0?[1-9]|1\d|2[0-8])[- /.]((0?[1-9])|(1[0-2]))[- /.]((1[6-9]|[2-9]\d)?\d{2})) (20|21|22|23|[0-1]?\d):[0-5]?\d:?[0-5]?\d$"
Local $sString = "1-1-2015 23:59:59"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")