import Foundation
let pattern = #"^((((31[- /.](0?[13578]|1[02]))|((29|30)[- /.](0?[1,3-9]|1[0-2])))[- /.](1[6-9]|[2-9]\d)?\d{2})|(29\/0?2[- /.](((1[6-9]|[2-9]\d)?(0[48]|[2468][048]|[13579][26])|((16|[2468][048]|[3579][26])00))))|(0?[1-9]|1\d|2[0-8])[- /.]((0?[1-9])|(1[0-2]))[- /.]((1[6-9]|[2-9]\d)?\d{2})) (20|21|22|23|[0-1]?\d):[0-5]?\d:?[0-5]?\d$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1-1-2015 23:59:59"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}