const regex = /^((((31[- /.](0?[13578]|1[02]))|((29|30)[- /.](0?[1,3-9]|1[0-2])))[- /.](1[6-9]|[2-9]\d)?\d{2})|(29\/0?2[- /.](((1[6-9]|[2-9]\d)?(0[48]|[2468][048]|[13579][26])|((16|[2468][048]|[3579][26])00))))|(0?[1-9]|1\d|2[0-8])[- /.]((0?[1-9])|(1[0-2]))[- /.]((1[6-9]|[2-9]\d)?\d{2})) (20|21|22|23|[0-1]?\d):[0-5]?\d:?[0-5]?\d$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((((31[- \/.](0?[13578]|1[02]))|((29|30)[- \/.](0?[1,3-9]|1[0-2])))[- \/.](1[6-9]|[2-9]\\d)?\\d{2})|(29\\\/0?2[- \/.](((1[6-9]|[2-9]\\d)?(0[48]|[2468][048]|[13579][26])|((16|[2468][048]|[3579][26])00))))|(0?[1-9]|1\\d|2[0-8])[- \/.]((0?[1-9])|(1[0-2]))[- \/.]((1[6-9]|[2-9]\\d)?\\d{2})) (20|21|22|23|[0-1]?\\d):[0-5]?\\d:?[0-5]?\\d$', '')
const str = `1-1-2015 23:59:59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}