// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((((31[- /.](0?[13578]|1[02]))|((29|30)[- /.](0?[1,3-9]|1[0-2])))[- /.](1[6-9]|[2-9]\d)?\d{2})|(29\/0?2[- /.](((1[6-9]|[2-9]\d)?(0[48]|[2468][048]|[13579][26])|((16|[2468][048]|[3579][26])00))))|(0?[1-9]|1\d|2[0-8])[- /.]((0?[1-9])|(1[0-2]))[- /.]((1[6-9]|[2-9]\d)?\d{2})) (20|21|22|23|[0-1]?\d):[0-5]?\d:?[0-5]?\d$").unwrap();
let string = "1-1-2015 23:59:59";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}