using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:j4fbanners|teststring2|teststring3)).*\.eu-.+\.amazonaws\.com$";
string input = @"s3-w.eu-central-1.amazonaws.com
j4fbanners.s3.eu-west-2.amazonaws.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}