re = /^(?!.*(?:j4fbanners|teststring2|teststring3)).*\.eu-.+\.amazonaws\.com$/m
str = 's3-w.eu-central-1.amazonaws.com
j4fbanners.s3.eu-west-2.amazonaws.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end