$re = '/^(?!.*(?:j4fbanners|teststring2|teststring3)).*\.eu-.+\.amazonaws\.com$/m';
$str = 's3-w.eu-central-1.amazonaws.com
j4fbanners.s3.eu-west-2.amazonaws.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);