import re
regex = re.compile(r"^(?!.*(?:j4fbanners|teststring2|teststring3)).*\.eu-.+\.amazonaws\.com$", flags=re.MULTILINE)
test_str = ("s3-w.eu-central-1.amazonaws.com\n"
"j4fbanners.s3.eu-west-2.amazonaws.com\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")