using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W\D";
string substitution = @"";
string input = @"Naveen-@01!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}