import Foundation
let pattern = #"\W\D"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Naveen-@01!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)