const regex = /\W\D/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W\\D', 'g')
const str = `Naveen-@01!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);