using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?P<d1>[:;|])\d+(?P<d2>(?!(?P=d1))[:;|])\w(?P=d1)\d(?P=d2)?";
string input = @"a:1;a:2
\w+(?P<d1>[:;|])\d+(?P<d2>(?!(?P=d1))[:;|])\w(?P=d1)\d(?P=d2)?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}