$re = '/\w+(?P<d1>[:;|])\d+(?P<d2>(?!(?P=d1))[:;|])\w(?P=d1)\d(?P=d2)?/';
$str = 'a:1;a:2
\\w+(?P<d1>[:;|])\\d+(?P<d2>(?!(?P=d1))[:;|])\\w(?P=d1)\\d(?P=d2)?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);