import re
regex = re.compile(r"\w+(?P<d1>[:;|])\d+(?P<d2>(?!(?P=d1))[:;|])\w(?P=d1)\d(?P=d2)?")
test_str = ("a:1;a:2\n\n\n"
"\\w+(?P<d1>[:;|])\\d+(?P<d2>(?!(?P=d1))[:;|])\\w(?P=d1)\\d(?P=d2)?")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")