re = /\w+(?P<d1>[:;|])\d+(?P<d2>(?!(?P=d1))[:;|])\w(?P=d1)\d(?P=d2)?/
str = 'a:1;a:2
\\w+(?P<d1>[:;|])\\d+(?P<d2>(?!(?P=d1))[:;|])\\w(?P=d1)\\d(?P=d2)?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end