#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})"
Local $sString = "ericabraham.ea@gmail.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)