package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})`)
var str = []byte(`ericabraham.ea@gmail.com`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}