import re
regex = re.compile(r"^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})")
test_str = "ericabraham.ea@gmail.com"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)