#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s[0-9]\s([A-Z]{2,3})([0-9\s]{4})\s([A-Z])\s\s([A-Z]{1,2})\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\s\s([A-Z]{3})([A-Z]{3})\s([A-Z0-9]{3})\s(X|\s)\s([0-9]{2})([0-9]{2})\s([0-9]{2})([0-9]{2})(\s|\*)([A-Z]*)\s(.*)"
Local $sString = "1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR" & @CRLF & _
"2ZSTKOS 13SEP UNBFML" & @CRLF & _
" 1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E" & @CRLF & _
" 2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E" & @CRLF & _
" ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES" & @CRLF & _
" 3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E" & @CRLF & _
" 4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E" & @CRLF & _
"FONE-2ZS00-T REISEBURO SAHIN 06042/951616"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")