import re
regex = re.compile(r"\s[0-9]\s([A-Z]{2,3})([0-9\s]{4})\s([A-Z])\s\s([A-Z]{1,2})\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\s\s([A-Z]{3})([A-Z]{3})\s([A-Z0-9]{3})\s(X|\s)\s([0-9]{2})([0-9]{2})\s([0-9]{2})([0-9]{2})(\s|\*)([A-Z]*)\s(.*)")
test_str = ("1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR\n"
"2ZSTKOS 13SEP UNBFML\n"
" 1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E\n"
" 2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E\n"
" ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES\n"
" 3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E\n"
" 4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E\n"
"FONE-2ZS00-T REISEBURO SAHIN 06042/951616")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")