using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s[0-9]\s([A-Z]{2,3})([0-9\s]{4})\s([A-Z])\s\s([A-Z]{1,2})\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\s\s([A-Z]{3})([A-Z]{3})\s([A-Z0-9]{3})\s(X|\s)\s([0-9]{2})([0-9]{2})\s([0-9]{2})([0-9]{2})(\s|\*)([A-Z]*)\s(.*)";
string input = @"1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR
2ZSTKOS 13SEP UNBFML
1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E
2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E
ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES
3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E
4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E
FONE-2ZS00-T REISEBURO SAHIN 06042/951616";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}