using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\/(?=packages|videos).*?\/(\d+)";
string input = @"<iframe src=""http://embed.app.com/packages/495"" width=""850"" height=""480"" frameborder=""0"" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe>
<iframe src=""https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0"" width=""960"" height=""540"" class=""responsive-embed""></iframe>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}