#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:<[^>]+>" & @CRLF & _
"|" & @CRLF & _
"(?<=>)\w+(?=<)" & @CRLF & _
")" & @CRLF & _
"(*SKIP)(*FAIL)" & @CRLF & _
"|" & @CRLF & _
"(\b\w+\b)"
Local $sString = "This is an image: <img src='/img.jpeg' /> This is a <a href='/abc.htm'/>Link</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")