$re = '~(?:<[^>]+>
|
(?<=>)\w+(?=<)
)
(*SKIP)(*FAIL)
|
(\b\w+\b)~x';
$str = 'This is an image: <img src=\'/img.jpeg\' /> This is a <a href=\'/abc.htm\'/>Link</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);