using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^>]+>
|
(?<=>)\w+(?=<)
)
(*SKIP)(*FAIL)
|
(\b\w+\b)";
string input = @"This is an image: <img src='/img.jpeg' /> This is a <a href='/abc.htm'/>Link</a>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}