import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<[^>]+>\n"
+ "|\n"
+ "(?<=>)\\w+(?=<)\n"
+ ")\n"
+ "(*SKIP)(*FAIL)\n"
+ "|\n"
+ "(\\b\\w+\\b)";
final String string = "This is an image: <img src='/img.jpeg' /> This is a <a href='/abc.htm'/>Link</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}