#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(((?:[^()]|\(\))+)\)"
Local $sString = "x (a) y -> a" & @CRLF & _
"x (a b) y -> a b" & @CRLF & _
"x (a b c) y -> a b c" & @CRLF & _
"x (a b() c) y -> a b() c" & @CRLF & _
"x (a() b() c) y -> a() b() c" & @CRLF & _
"x (a b() c()) y -> a b() c()" & @CRLF & _
"x (a b(a) c) y -> a" & @CRLF & _
"x (a (b() c)) y -> b() c" & @CRLF & _
"x () y -> empty" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")