import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(((?:[^()]|\\(\\))+)\\)";
final String string = "x (a) y -> a\n"
+ "x (a b) y -> a b\n"
+ "x (a b c) y -> a b c\n"
+ "x (a b() c) y -> a b() c\n"
+ "x (a() b() c) y -> a() b() c\n"
+ "x (a b() c()) y -> a b() c()\n"
+ "x (a b(a) c) y -> a\n"
+ "x (a (b() c)) y -> b() c\n"
+ "x () y -> empty\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}