package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<item>.+?)\-\s(?P<food>.*?\)).*?\((?P<cost>\d)\s\w+\)\s\[.*?(?P<extra>\d+(\.\d+)?).*\].*\[.*?(?P<required>\d+(\.\d+)?).*\]`)
var str = `1- Baby Carrots (4Kids) (3 DOLLARS) [EXTRA 0 COUNT]; [REQUIRED 5 COUNT]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}