import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<item>.+?)\\-\\s(?P<food>.*?\\)).*?\\((?P<cost>\\d)\\s\\w+\\)\\s\\[.*?(?P<extra>\\d+(\\.\\d+)?).*\\].*\\[.*?(?P<required>\\d+(\\.\\d+)?).*\\]";
final String string = "1- Baby Carrots (4Kids) (3 DOLLARS) [EXTRA 0 COUNT]; [REQUIRED 5 COUNT]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}