$re = '/(?P<item>.+?)\-\s(?P<food>.*?\)).*?\((?P<cost>\d)\s\w+\)\s\[.*?(?P<extra>\d+(\.\d+)?).*\].*\[.*?(?P<required>\d+(\.\d+)?).*\]/';
$str = '1- Baby Carrots (4Kids) (3 DOLLARS) [EXTRA 0 COUNT]; [REQUIRED 5 COUNT]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);