const regex = new RegExp('(?P<item>.+?)\\-\\s(?P<food>.*?\\)).*?\\((?P<cost>\\d)\\s\\w+\\)\\s\\[.*?(?P<extra>\\d+(\\.\\d+)?).*\\].*\\[.*?(?P<required>\\d+(\\.\\d+)?).*\\]', 'g')
const str = `1- Baby Carrots (4Kids) (3 DOLLARS) [EXTRA 0 COUNT]; [REQUIRED 5 COUNT]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}