using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe.*?src=""(?![^""]*(?:youtube|vimeo|soundcloud)).*?<\/iframe>";
string input = @"<p><iframe src=""http://www.3you3tube.com/embed/YoX1yc92MOU"" width=""500"" height=""300"" frameborder=""0"" scrolling=""auto""></iframe></p>
29 <p>text daily to place domain staff as volunteers with charity partners, we know all too well that the ""V"" word can sometimes be misunderstood. Occasionally seen as a dusty, worthy word, it can conjure images of coffee mornings and bric-a-brac stalls. So its not always as easy as you might think to get people to embrace their inner-volunteer. That's why the <a href=""http://www.domain.co.uk/sdfn/2010/11/connect-create-domain-volunteers.shtml"">Conne<p><iframe src=""http://www.youtube.com/embed/YoX1yc92MOU"" width=""500"" height=""300"" frameborder=""0"" scrolling=""auto""></iframe></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}