import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe.*?src=\"(?![^\"]*(?:youtube|vimeo|soundcloud)).*?<\\/iframe>";
final String string = "<p><iframe src=\"http://www.3you3tube.com/embed/YoX1yc92MOU\" width=\"500\" height=\"300\" frameborder=\"0\" scrolling=\"auto\"></iframe></p>\n"
+ "29 <p>text daily to place domain staff as volunteers with charity partners, we know all too well that the \"V\" word can sometimes be misunderstood. Occasionally seen as a dusty, worthy word, it can conjure images of coffee mornings and bric-a-brac stalls. So its not always as easy as you might think to get people to embrace their inner-volunteer. That's why the <a href=\"http://www.domain.co.uk/sdfn/2010/11/connect-create-domain-volunteers.shtml\">Conne<p><iframe src=\"http://www.youtube.com/embed/YoX1yc92MOU\" width=\"500\" height=\"300\" frameborder=\"0\" scrolling=\"auto\"></iframe></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}