# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<iframe.*?src=\"(?![^\"]*(?:youtube|vimeo|soundcloud)).*?<\/iframe>"
test_str = ("<p><iframe src=\"http://www.3you3tube.com/embed/YoX1yc92MOU\" width=\"500\" height=\"300\" frameborder=\"0\" scrolling=\"auto\"></iframe></p>\n"
"29 <p>text daily to place domain staff as volunteers with charity partners, we know all too well that the \"V\" word can sometimes be misunderstood. Occasionally seen as a dusty, worthy word, it can conjure images of coffee mornings and bric-a-brac stalls. So its not always as easy as you might think to get people to embrace their inner-volunteer. That's why the <a href=\"http://www.domain.co.uk/sdfn/2010/11/connect-create-domain-volunteers.shtml\">Conne<p><iframe src=\"http://www.youtube.com/embed/YoX1yc92MOU\" width=\"500\" height=\"300\" frameborder=\"0\" scrolling=\"auto\"></iframe></p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.