package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Payment received NEFT \- Your account (\S+) has been credited for (\S+) from (\S+) vide Txn ref (\S+)`)
var str = `Payment received NEFT - Your account account_number has been credited for some_amount from some_sender vide Txn ref some_ref_num.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}