$re = '/Payment received NEFT \- Your account (\S+) has been credited for (\S+) from (\S+) vide Txn ref (\S+)/m';
$str = 'Payment received NEFT - Your account account_number has been credited for some_amount from some_sender vide Txn ref some_ref_num.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;