import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Payment received NEFT \\- Your account (\\S+) has been credited for (\\S+) from (\\S+) vide Txn ref (\\S+)";
final String string = "Payment received NEFT - Your account account_number has been credited for some_amount from some_sender vide Txn ref some_ref_num.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}